Bug 80835

Summary: Style checker complains about naming parameter with default values
Product: WebKit Reporter: Antonio Gomes <tonikitoo>
Component: Tools / TestsAssignee: Nobody <webkit-unassigned>
Status: RESOLVED INVALID    
Severity: Normal CC: abarth, ap, zan
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   

Antonio Gomes
Reported 2012-03-12 07:26:16 PDT
It happened in https://bugs.webkit.org/show_bug.cgi?id=79611#c4 Code looks like this: - void calculateScrollbarModesForLayout(ScrollbarMode& hMode, ScrollbarMode& vMode); + void calculateScrollbarModesForLayout(ScrollbarMode& hMode, ScrollbarMode& vMode, ScrollbarModesCalculationStrategy strategy = AnyRule); and the code style checker complained that 'strategy' added not value: >> Source/WebCore/page/FrameView.h:283: The parameter name "strategy" adds no information, so it should be removed. [readability/parameter_name] [5] However it is needed, given the default value.
Attachments
Alexey Proskuryakov
Comment 1 2012-03-12 10:04:33 PDT
Actually, this should work: + void calculateScrollbarModesForLayout(ScrollbarMode& hMode, ScrollbarMode& vMode, ScrollbarModesCalculationStrategy = AnyRule);
Antonio Gomes
Comment 2 2012-03-12 10:24:39 PDT
(In reply to comment #1) > Actually, this should work: > > + void calculateScrollbarModesForLayout(ScrollbarMode& hMode, ScrollbarMode& vMode, ScrollbarModesCalculationStrategy = AnyRule); oh thanks, so this is INVALID.
David Levin
Comment 3 2012-12-28 08:34:33 PST
*** Bug 105831 has been marked as a duplicate of this bug. ***
Note You need to log in before you can comment on or make changes to this bug.