Bug 244615

Summary: Replace WEBKIT2_COMPILATION and JSC_COMPILATION with BUILDING_WEBKIT
Product: WebKit Reporter: Michael Catanzaro <mcatanzaro>
Component: WebKit Misc.Assignee: Michael Catanzaro <mcatanzaro>
Status: RESOLVED FIXED    
Severity: Normal CC: bugs-noreply, mcatanzaro, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: PC   
OS: Linux   
Bug Depends on:    
Bug Blocks: 228250    

Michael Catanzaro
Reported 2022-08-31 10:04:00 PDT
Trying to reduce more legacy WebKit2 branding, I first wanted to rename WEBKIT2_COMPILATION to WEBKIT_COMPILATION. But that's almost redundant with BUILDING_WEBKIT, which is used in more places. I don't think we need both. We don't need a separate preprocessor definition to distinguish between building Source/WebKit vs. other components of WebKit because Source/WebKit does not have any export macros, and it would be extremely confusing to try to maintain such a distinction anyway. Defining BUILDING_WEBKIT everywhere simplifies things. Currently it's actually defined separately for each port, only when building Source/WebKit, but this is confusing and annoying as tests often need to include private headers, so it's easier if we move it to a global location.
Attachments
Michael Catanzaro
Comment 1 2022-08-31 11:08:56 PDT
EWS
Comment 2 2022-09-01 06:56:11 PDT
Committed 254039@main (f4e1ac8eb7d2): <https://commits.webkit.org/254039@main> Reviewed commits have been landed. Closing PR #3862 and removing active labels.
Radar WebKit Bug Importer
Comment 3 2022-09-01 06:57:25 PDT
Note You need to log in before you can comment on or make changes to this bug.