Bug 102270

Summary: IndexedDB: Replace int64 with int64_t
Product: WebKit Reporter: Michael Pruett <michael>
Component: New BugsAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: alecflett, jsbell, tony, webkit.review.bot
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 45110    
Attachments:
Description Flags
Replace int64 with int64_t
tony: review+
Replace int64 with int64_t none

Michael Pruett
Reported 2012-11-14 12:33:58 PST
There are currently two uses of the non-standard type int64 in IndexedDB which should be changed to the C99/C++11 int64_t type. The int64 type is defined in Chromium's basictypes.h but is not defined for other platforms.
Attachments
Replace int64 with int64_t (3.02 KB, patch)
2012-11-14 12:38 PST, Michael Pruett
tony: review+
Replace int64 with int64_t (3.09 KB, patch)
2012-11-14 13:33 PST, Michael Pruett
no flags
Michael Pruett
Comment 1 2012-11-14 12:38:39 PST
Created attachment 174228 [details] Replace int64 with int64_t
Tony Chang
Comment 2 2012-11-14 13:23:14 PST
Comment on attachment 174228 [details] Replace int64 with int64_t View in context: https://bugs.webkit.org/attachment.cgi?id=174228&action=review > Source/WebCore/ChangeLog:8 > + > + Tests: storage/indexeddb/* Please put the reason for the change here. For example, "This is needed for JSC because ...".
Joshua Bell
Comment 3 2012-11-14 13:24:37 PST
> Please put the reason for the change here. For example, "This is needed for JSC because ...". And "Cleaning up coding inconsistencies, no behavior change" is acceptable as a reason.
Michael Pruett
Comment 4 2012-11-14 13:33:57 PST
Created attachment 174242 [details] Replace int64 with int64_t
WebKit Review Bot
Comment 5 2012-11-14 14:12:53 PST
Comment on attachment 174242 [details] Replace int64 with int64_t Rejecting attachment 174242 [details] from commit-queue. Failed to run "['/mnt/git/webkit-commit-queue/Tools/Scripts/webkit-patch', '--status-host=queues.webkit.org', '-..." exit_code: 2 Last 500 characters of output: : Merge conflict in Source/WebCore/ChangeLog Failed to merge in the changes. Patch failed at 0001 Coordinated Graphics: Rename m_CoordinatedGraphicsLayerClient to m_coordinator When you have resolved this problem run "git rebase --continue". If you would prefer to skip this patch, instead run "git rebase --skip". To restore the original branch and stop rebasing run "git rebase --abort". rebase refs/remotes/origin/master: command returned error: 1 Died at Tools/Scripts/update-webkit line 154. Full output: http://queues.webkit.org/results/14832512
WebKit Review Bot
Comment 6 2012-11-14 14:42:48 PST
Comment on attachment 174242 [details] Replace int64 with int64_t Clearing flags on attachment: 174242 Committed r134673: <http://trac.webkit.org/changeset/134673>
WebKit Review Bot
Comment 7 2012-11-14 14:42:52 PST
All reviewed patches have been landed. Closing bug.
Note You need to log in before you can comment on or make changes to this bug.